WooCommerce提示soapclient未启用,如何启用?

WooCommerce状态栏中提示:您的服务器未启用 SoapClient 类 – 某些使用SOAP的支付网关插件可能会罢工。我的天那,都要罢工了,并且和支付相关,这能不马上处理吗?如果你是用宝塔面板搭建的,也不用着急,这里汇总了不同版本的php对应的代码,通过这一小段代码就可以解决这个问题。

soapclient未启用

1.Centos系统

PHP7.0、7.1、7.2、7.3、7.4、8.0版本对应的代码分别如下:

yum install lsphp70-soap -y
yum install lsphp71-soap -y
yum install lsphp72-soap -y
yum install lsphp73-soap -y
yum install lsphp74-soap -y
yum install lsphp80-soap -y

2.Ubuntu/Debian系统

PHP7.0、7.1、7.2、7.3、7.4、8.0版本对应的代码分别如下:

apt install lsphp70-soap -y
apt install lsphp71-soap -y
apt install lsphp72-soap -y
apt install lsphp73-soap -y
apt install lsphp74-soap -y
apt install lsphp80-soap -y

最后

在复制代码前,先看下你的服务器是安装哪个版本的PHP,则复制对应版本的代码,通过SSH工具远程工具执行代码即可。常见的免费SSH工具主要有:PuttyFinalshell等。

本文作者:自由超
本文标题:《WooCommerce提示soapclient未启用,如何启用?》
本文链接:https://freechao.com/5468.html
发布日期:2023年06月03日 21:47:11
更新日期:2024年03月06日 20:15:56
版权声明:除特殊注明,均为作者原创内容,遵守CC-BY-NC 4.0版权协议,转发请保留原文链接!
免责声明:文中如涉及第三方资源,均来自互联网,仅供学习研究,禁止商业使用,如有侵权,联系我们24小时内删除!
分享给更多人

留下评论

您的电子邮箱地址不会被公开。 必填项已用 * 标注